User Tools

Site Tools


cisco:labs:ios:lab2

IOS Lab Misc 1: eBGP AS_PATH Lab

Router Configurations

hostname Router11
!
interface Loopback1
 ip address 10.1.1.1 255.255.255.0
!
interface GigabitEthernet0/0
 description R2
 ip address 10.0.0.1 255.255.255.252
!
interface GigabitEthernet0/1
 description Router13
 ip address 10.0.0.14 255.255.255.252
!
router bgp 1
 bgp router-id 1.1.1.1
 bgp log-neighbor-changes
 network 10.0.0.12 mask 255.255.255.252
 network 10.1.1.0 mask 255.255.255.0
 neighbor 10.0.0.2 remote-as 2
 neighbor 10.0.0.13 remote-as 3
hostname Router12
!
interface GigabitEthernet0/0
 description Router11
 ip address 10.0.0.2 255.255.255.252
!
interface GigabitEthernet0/1
 description Router14
 ip address 10.0.0.5 255.255.255.252
!
router bgp 2
 bgp router-id 2.2.2.2
 bgp log-neighbor-changes
 network 10.0.0.0 mask 255.255.255.252
 network 10.0.0.4 mask 255.255.255.252
 neighbor 10.0.0.1 remote-as 1
 neighbor 10.0.0.6 remote-as 4
hostname Router14
!
interface GigabitEthernet0/0
 description Router13
 ip address 10.0.0.9 255.255.255.252
!
interface GigabitEthernet0/1
 description Router12
 ip address 10.0.0.6 255.255.255.252
!
router bgp 4
 bgp router-id 4.4.4.4
 bgp log-neighbor-changes
 network 10.0.0.4 mask 255.255.255.252
 network 10.0.0.8 mask 255.255.255.252
 neighbor 10.0.0.5 remote-as 2
 neighbor 10.0.0.10 remote-as 3
hostname Router13
!
interface GigabitEthernet0/0
 description Router14
 ip address 10.0.0.10 255.255.255.252
!
interface GigabitEthernet0/1
 description Router 11
 ip address 10.0.0.13 255.255.255.252
!
router bgp 3
 bgp router-id 3.3.3.3
 bgp log-neighbor-changes
 network 10.0.0.8 mask 255.255.255.252
 network 10.0.0.12 mask 255.255.255.252
 neighbor 10.0.0.9 remote-as 4
 neighbor 10.0.0.14 remote-as 1

Verification

Router11#show ip bgp ipv4 unicast
BGP table version is 10, local router ID is 1.1.1.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal, 
              r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter, 
              x best-external, a additional-path, c RIB-compressed, 
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI validation codes: V valid, I invalid, N Not found

     Network          Next Hop            Metric LocPrf Weight Path
 r   10.0.0.0/30      10.0.0.13                              0 3 4 2 i
 r>                   10.0.0.2                 0             0 2 i
 *   10.0.0.4/30      10.0.0.13                              0 3 4 i
 *>                   10.0.0.2                 0             0 2 i
 *>  10.0.0.8/30      10.0.0.13                0             0 3 i
 *                    10.0.0.2                               0 2 4 i
 *   10.0.0.12/30     10.0.0.13                0             0 3 i
 *>                   0.0.0.0                  0         32768 i
 *>  10.1.1.0/24      0.0.0.0                  0         32768 i
Router12#ping 10.1.1.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 3/4/5 ms
---------------
Router14#ping 10.1.1.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 5/5/6 ms
---------------
Router13#ping 10.1.1.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/5/9 ms

IOS Lab Homepage
Labs Homepage

cisco/labs/ios/lab2.txt · Last modified: 2020/01/30 13:05 by Derg Enterprises