User Tools

Site Tools


cisco:dmvpn:eigrp_phase_1-2

Cisco DMVPN Phase 1 and 2 with EIGRP

Notes

NHRP Hub configuration:

  1. Create a tunnel interface on bos1
    1. interface Tunnel0
        ip address 172.30.30.1 255.255.255.0
  2. Add private network to routing protocol.
    1. router eigrp 30
        network 172.30.30.0
  3. Identify NHRP network-id (like an OSPF area 0).
    1. interface Tunnel0
        ip nhrp network-id 30
  4. Allow multicast traffic to traverse DMVPN infrastructure.
    1. interface Tunnel0
        ip nhrp map multicast dynamic
  5. Add a tunnel source.
    1. interface Tunnel0
        tunnel source GigabitEthernet0/2
  6. Tunnel source is the IP to connect to the NHRP network-id 30.
    1. Aka: the public facing interface.
  7. Define mode to operate tunnel in.
    1. interface Tunnel0
        tunnel mode gre multipoint
  8. Tunnel will come up.
  9. Now spokes can be added.

• NHRP Spoke configuration:

  1. Create a tunnel interface on tpa1
    1. interface Tunnel0
        ip address 172.30.30.2 255.255.255.0
  2. Add private network to routing protocol.
    1. router eigrp 30
        network 172.30.30.0
  3. Define NHRP network-id.
    1. interface Tunnel0
        ip nhrp network-id 30
  4. Define tunnel address of the NHRP server (hub).
    1. interface Tunnel0
        ip nhrp nhs 172.30.30.1
  5. Map NHRP server address to publicly reachable IP.
    1. interface Tunnel0
        ip nhrp map 172.30.30.1 10.0.30.1
  6. Send all multicast traffic to the public IP only.
    1. interface Tunnel0
        ip nhrp map multicast 10.0.30.1
  7. Add a tunnel source
    1. interface Tunnel0
        tunnel source GigabitEthernet0/2
      1. Tunnel source is the IP to connect to the NHRP network-id 30.
      2. Aka: the public facing interface.
  8. Define mode to operate tunnel in.
    1. interface Tunnel0
        tunnel mode gre multipoint
  9. Tunnel will come up.
  10. Repeat NHRP Spoke configuration on each spoke
  11. To verify:
    1. show ip eigrp nei
      1. Shows neighborship of NHRP Hub at 172.30.30.1.
    2. show ip route eigrp
      1. Shows that EIGRP has learned additional routes through the tunnel interface.
    3. traceroute {IP of spoke}
      1. Can see hops a packet takes to reach a destination.
  12. To allow spoke to spoke communication with EIGRP, split horizon needs to be disabled on the NHRP Hub.
    1. interface Tunnel0
          no ip split-horizon eigrp 30
  13. Now the spokes go through the hub to reach another spoke.
  14. This behavior can be modified to allow spoke to spoke communication without going through the hub.

DMPVN Phase 2

  1. Configure hub
    1. interface Tunnel0
        no ip next-hop-self eigrp 30
  2. Now packets will flow spoke to spoke without using the hub as a next hop. This creates a dynamic spoke to spoke Phase 2 tunnel and allows a more efficient way for spokes to communicate with each other.

Topology

Device Configurations

  • pe1
    • Config
  • ny1
    • Config
  • ny2
    • Config
  • co1
    • Config
  • co2
    • Config
  • ga1
    • Config
  • ga2
    • Config
  • tn1
    • Config
  • tn2
    • Config
  • tx1
    • Config
  • tx2
    • Config
cisco/dmvpn/eigrp_phase_1-2.txt · Last modified: 2021/12/25 17:27 by Derg Enterprises