User Tools

Site Tools


juniper:commands

Commands

  • root@% cli
    • root> request system zeroize
  • root> edit
    • Entering configuration mode

[edit] root# delete This will delete the entire configuration Delete everything under this level? [yes,no] (no) yes

[edit] root#

  • [edit]

root# set system host-name LabFW2

  • [edit]

root# set system root-authentication plain-text-password New password: Retype new password:

  • root# set system login user tim authentication plain-text-password

New password: Retype new password:

  • [edit]

root# set system login user timm class super-user

  • [edit]

root# rename system login user timm to user tim

  • [edit]

root# set system login user tim full-name "Tim Panther"

  • [edit]

root# set system host-name LLabFW22

[edit] root# delete system host-name LLabFW22

[edit] root# set system host-name LabFW2

  • [edit]

root# show ## Last changed: 2016-09-26 02:10:34 UTC version 12.1X46-D40.2; system {

  host-name LabFW2;
  root-authentication {
      encrypted-password "$1$SVE6qJyk$yKV8ZoWhG40Sb/IS/va.60"; ## SECRET-DATA
  }
  login {
      user tim {
          full-name "Tim Panther";
          class super-user;
          authentication {
              encrypted-password "$1$b1ak3jfX$CC62JkTQSpT1KojlKTKYt."; ## SECRET-DATA
          }
      }
  }

}

  • [edit]

root# show | display set set version 12.1X46-D40.2 set system host-name LabFW2 set system root-authentication encrypted-password "$1$SVE6qJyk$yKV8ZoWhG40Sb/IS/va.60" set system login user tim full-name "Tim Panther" set system login user tim class super-user set system login user tim authentication encrypted-password "$1$b1ak3jfX$CC62JkTQSpT1KojlKTKYt."

  • [edit]

root# commit check configuration check succeeds

[edit] root# commit comment "Initial setup for lab" commit complete

[edit] root@LabFW2# quit Exiting configuration mode

root@LabFW2> show system commit 0 2016-09-26 02:17:42 UTC by root via cli

  Initial setup for lab

1 2016-09-26 00:59:12 UTC by root via other

root@LabFW2>

  • Juniper default passwords:
    • juniper1
    • juniper123
    • cisco
  • [edit]

root@LabJR13# edit protocols bgp

[edit protocols bgp] root@LabJR13# top

[edit] root@LabJR13# edit protocols bgp

[edit protocols bgp] root@LabJR13# up

[edit protocols] root@LabJR13# up

[edit] root@LabJR13# edit protocols bgp

[edit protocols bgp] root@LabJR13# up 2

[edit] root@LabJR13#

  • root@LabJR13> request system reboot
  • root@LabFW1> request system power-off
  • root@LabJR13> request system power-off message "Turning off in 10 hours"

Disable Security for firewalls

This is needed to make the firewalls' interfaces into router interfaces.

  • [edit]

root@LabFW1-J1# show | compare [edit]

security {
    forwarding-options {
        family {
            inet6 {
                mode packet-based;
            }
            mpls {
                mode packet-based;
            }
            iso {
                mode packet-based;
            }
        }
    }
}

Or you can type:

  • set security forwarding-options family inet6 mode packet-based
  • set security forwarding-options family mpls mode packet-based
  • set security forwarding-options family iso mode packet-based

Edit Interfaces

* [edit]
interfaces {
    ge-0/0/0 {
        unit 0 {
            family inet {
                address 192.168.12.1/24;
            }
        }
    }
    fe-0/0/2 {
        unit 0 {
            family inet {
                address 192.168.13.1/24;
            }
        }
    }
    fe-0/0/7 {
        unit 0 {
            family inet {
                address 192.168.14.1/24;
* or you can type:
  * set interfaces fe-0/0/7 unit 0 family inet address 192.168.14.1/24
juniper/commands.txt · Last modified: 2022/08/30 07:31 by Derg Enterprises