LACP between a Router and Switch

Router config:
interface Port-channel1
no ip address
hold-queue 150 in
!
interface Port-channel1.17
description wired data
encapsulation dot1Q 17 native
ip address 192.168.17.254 255.255.255.0
!
interface Port-channel1.18
description wired voice
encapsulation dot1Q 18
ip address 192.168.18.254 255.255.255.0
!
interface GigabitEthernet0/1
description Port-channel1
no ip address
duplex auto
speed auto
channel-group 1
!
interface GigabitEthernet0/2
description Port-channel1
no ip address
duplex auto
speed auto
channel-group 1
!
! Note: The router will now show a port-channel status, but the switch will.
------------------------------
 
Switch config:
vlan 17
name data
!
vlan 18
name voice
!
interface Port-channel1
description Router connection
switchport trunk encapsulation dot1q
switchport trunk native vlan 17
switchport trunk allowed vlan 17,18
switchport mode trunk
!
interface GigabitEthernet1/0/45
switchport trunk encapsulation dot1q
switchport trunk native vlan 17
switchport trunk allowed vlan 17,18
switchport mode trunk
channel-group 1 mode on
!
interface GigabitEthernet1/0/46
switchport trunk encapsulation dot1q
switchport trunk native vlan 17
switchport trunk allowed vlan 17,18
switchport mode trunk
channel-group 1 mode on
!
interface Vlan1
no ip address
shutdown
!
interface Vlan17
ip address 192.168.17.2 255.255.255.0
!
ip default-gateway 192.168.17.1
ip route 0.0.0.0 0.0.0.0 192.168.17.1
!
! Note: Verify port-channel connectivity with:
!       show etherchannel-summary